Quantcast

removing LinguaPlone

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

removing LinguaPlone

Lee Pool
Hi


I am trying to remove LinguaPlone from my plone website.


1.) I deactivate it from Add-on's in the Control Panel.
2.) I remove it from the buildout.cfg
3.) do the buildout
4.) Start my instance in debug mode (i.e.) fg.


I then get this error:

###################################

Traceback (innermost last):

Module ZPublisher.Publish, line 247, in publish_module_standard
Module zope.publisher.skinnable, line 46, in setDefaultSkin
Module ZODB.Connection, line 860, in setstate
Module ZODB.Connection, line 914, in _setstate
Module ZODB.serialize, line 612, in setGhostState
Module ZODB.serialize, line 605, in getState
Module copy_reg, line 48, in _reconstructor
TypeError: ('object.__new__(SyncedLanguages) is not safe, use
Persistence.Persistent.__new__()', <function _reconstructor at
0x7f8d850dfaa0>, (<class
'Products.LinguaPlone.vocabulary.SyncedLanguages'>, <type 'object'>, None))


#########################################

Adding it back in.

>From the buildout:

The following part definition lists the versions picked:
[versions]
MySQL-python = 1.2.5
Products.LinguaPlone = 4.1.3
Products.PloneFormGen = 1.7.16
Products.PythonField = 1.1.3
Products.TALESField = 1.1.3
Products.TemplateFields = 1.2.5
Products.WebServerAuth = 1.7
Products.ZMySQLDA = 3.1.1
collective.captcha = 1.7
plone.app.ldap = 1.3.1
plone.recipe.command = 1.1
plone.recipe.precompiler = 0.6

# Required by:
# Products.PloneLDAP==1.2
Products.LDAPMultiPlugins = 1.14

# Required by:
# Products.PloneLDAP==1.2
Products.LDAPUserFolder = 2.27

# Required by:
# plone.app.ldap==1.3.1
Products.PloneLDAP = 1.2

# Required by:
# Products.LDAPUserFolder==2.27
dataflake.fakeldap = 1.1

# Required by:
# collective.captcha==1.7
skimpyGimpy = 1.4

################################3


Restarting the plone instance, and I can get back in.

Version Overview
Plone 4.3.3 (4308)
CMF 2.2.7
Zope 2.13.22
Python 2.7.9 (default, Mar 1 2015, 12:57:24) [GCC 4.9.2]
PIL 2.3.0 (Pillow)


1.) The purpose of removing LinguaPlone is such that I can
upgrade/migrate our site to Plone 5.

2.)
http://quintagroup.com/services/support/tutorials/plone.app.multilingual
 <--- to install this, as multilingual support is required for out website.


Lee




------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity planning
reports.http://sdm.link/zohodev2dev
_______________________________________________
Plone-i18n mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-i18n
Loading...