Quantcast

buildout problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

buildout problem

Erwin Geeraerts
Dear,
 
After having installed Plone 4.0.9,
& uncommenting some products in the default buildout:
...
 
# Example products:
# * LinguaPlone provides tools for building multi-lingual sites
# * PloneFormGen provides through-the-web form building
#
    Products.LinguaPlone==4.0.1
    Products.PloneFormGen==1.6.0
...
 
I ran :
 
srvplone01# bin/buildout
Uninstalling zopepy.
Uninstalling client2.
Uninstalling client1.
Updating zeoserver.
Installing client1.
Download error: timed out -- Some packages may not be found!
Download error: timed out -- Some packages may not be found!
Couldn't find index page for 'Products.LinguaPlone' (maybe misspelled?)
Download error: timed out -- Some packages may not be found!
Getting distribution for 'Products.LinguaPlone==4.0.1'.
While:
  Installing client1.
  Getting distribution for 'Products.LinguaPlone==4.0.1'.
Error: Couldn't find a distribution for 'Products.LinguaPlone==4.0.1'.
*************** PICKED VERSIONS ****************
[versions]
*************** /PICKED VERSIONS ***************
srvplone01# uname -a
FreeBSD srvplone01.yourict.net 8.2-RELEASE FreeBSD 8.2-RELEASE #0: Fri Feb 18 02:24:46 UTC 2011     [hidden email]:/usr/obj/usr/src/sys/GENERIC  i386
 
In my environment I have set http_proxy, ...
 
Thanks in advance for any help or advice.
 
Best regards,
Erwin Geeraerts
 

------------------------------------------------------------------------------
LIMITED TIME SALE - Full Year of Microsoft Training For Just $49.99!
1,500+ hours of tutorials including VisualStudio 2012, Windows 8, SharePoint
2013, SQL 2012, MVC 4, more. BEST VALUE: New Multi-Library Power Pack includes
Mobile, Cloud, Java, and UX Design. Lowest price ever! Ends 9/20/13.
http://pubads.g.doubleclick.net/gampad/clk?id=58041151&iu=/4140/ostg.clktrk
_______________________________________________
Plone-i18n mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-i18n
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: buildout problem

Maurits van Rees-3
Op 19-09-13 16:21, Erwin Geeraerts schreef:

> Dear,
> After having installed Plone 4.0.9,
> & uncommenting some products in the default buildout:
> ...
> # Example products:
> # * LinguaPlone provides tools for building multi-lingual sites
> # * PloneFormGen provides through-the-web form building
> #
>      Products.LinguaPlone==4.0.1
>      Products.PloneFormGen==1.6.0
> ...
> I ran :
> srvplone01# bin/buildout
> Uninstalling zopepy.
> Uninstalling client2.
> Uninstalling client1.
> Updating zeoserver.
> Installing client1.
> Download error: timed out -- Some packages may not be found!
> Download error: timed out -- Some packages may not be found!
> Couldn't find index page for 'Products.LinguaPlone' (maybe misspelled?)
> Download error: timed out -- Some packages may not be found!
> Getting distribution for 'Products.LinguaPlone==4.0.1'.
> While:
>    Installing client1.
>    Getting distribution for 'Products.LinguaPlone==4.0.1'.
> Error: Couldn't find a distribution for 'Products.LinguaPlone==4.0.1'.
> *************** PICKED VERSIONS ****************
> [versions]
> *************** /PICKED VERSIONS ***************
> srvplone01# uname -a
> FreeBSD srvplone01.yourict.net <http://srvplone01.yourict.net>
> 8.2-RELEASE FreeBSD 8.2-RELEASE #0: Fri Feb 18 02:24:46 UTC 2011
> [hidden email]:/usr/obj/usr/src/sys/GENERIC
> i386
> In my environment I have set http_proxy, ...
> Thanks in advance for any help or advice.
> Best regards,
> Erwin Geeraerts

I am not sure if buildout respects and uses the http proxy setting.
Well, if the bootstrap worked, then it sounds like it should work.

LinguaPlone should be automatically downloaded from here:
https://pypi.python.org/simple/Products.LinguaPlone/
Can you download the 4.0.1 version from that page with curl or wget or
some other tool on your server, to see if that at least works?

Some suggestions:

- There might have been a network failure somewhere and it might just
work when you try it again.

- You can run 'bin/buildout -v' for more verbose output.  Add more 'v's
for more (far too much) verbosity.

- This should have nothing to do with LinguaPlone.  You can comment that
out and see if the buildout finishes correctly without it.

- Since it has nothing to do with LinguaPlone or internationalization,
this question might be better asked on the setup list or the user list.
  I don't think anyone minds having it here, but you get more eyeballs
on the other lists.

- Plone 4.0.9 is a bit old.  If you are just starting with Plone, I
suggest using the latests 4.3.2.  I don't expect that this has any
effect on this problem though.  Well, maybe 4.2.6, because I am not sure
if LinguaPlone is compatible with Plone 4.3 yet.

- The new kid on the block for multilingual sites is
plone.app.multilingual.  Should work fine replacing LinguaPlone, but
it's a work in progress.  Also, this still should have nothing to do
with your download error.


--
Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl


------------------------------------------------------------------------------
LIMITED TIME SALE - Full Year of Microsoft Training For Just $49.99!
1,500+ hours of tutorials including VisualStudio 2012, Windows 8, SharePoint
2013, SQL 2012, MVC 4, more. BEST VALUE: New Multi-Library Power Pack includes
Mobile, Cloud, Java, and UX Design. Lowest price ever! Ends 9/20/13.
http://pubads.g.doubleclick.net/gampad/clk?id=58041151&iu=/4140/ostg.clktrk
_______________________________________________
Plone-i18n mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/plone-i18n
Loading...