Upgrade di Plone - portal_setup e plone.app.theming

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade di Plone - portal_setup e plone.app.theming

Lorenzo Maurizi - C.S.I.A. UniMC

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

R: Upgrade di Plone - portal_setup e plone.app.theming

Lorenzo Maurizi - C.S.I.A. UniMC

Mi rispondo da solo:

 

il prodotto "plone.app.theming" dovrebbe essere quello denominato Supporto ai temi Diazo nel portal_quickinstaller.

Effettivamente, installando quel prodotto, l'errore scompare.

Ma rimuovendo il prodotto, perdo del tutto l'icona dei temi.

Come funziona allora? Come posso ripristinare la situazione precedente? Undo?

Grazie!

Ciao da Lorenzo

 

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

R: Upgrade di Plone - portal_setup e plone.app.theming

Lorenzo Maurizi - C.S.I.A. UniMC
In reply to this post by Lorenzo Maurizi - C.S.I.A. UniMC

Altra domanda:

gli upgrades presenti in portal_setup vanno fatti tutti? Qual è la ratio? Ho visto che applicando alcuni upgrades mi vengono installati dei prodotti che prima non avevo installati.

 

Grazie in anticipo.

Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

Re: R: Upgrade di Plone - portal_setup e plone.app.theming

Luca Fabbri-2
Il portal_setup è un tool di basso livello, non è saggio entrarci e lanciare upgrade senza sapere che cosa comportano. Normalmente (per prodotti fatti "bene") gli upgrade che trovi lì sono tradotti in aggiornamenti di prodotti dalla più comoda interfaccia di Plone.

Se puoi tornare alla versione precedente del tuo sito (da un backup) è meglio, oppure usa gli undo, come hai detto prima.

Per il tuo problema originale: sembrerebbe un qualche tipo di problema di migrazione (l'upgrade di Plone avrebbe dovuto fare quel lavoro al tuo posto) e in quel caso hai fatto probabilmente bene a lanciare l'aggiornamento.
In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo provoca un reset delle impostazioni del prodotto alla configurazione iniziale.

In ogni caso: tutto questo va sempre fatto con attenzione (==backup).




2014-07-01 13:46 GMT+02:00 Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]>:

Altra domanda:

gli upgrades presenti in portal_setup vanno fatti tutti? Qual è la ratio? Ho visto che applicando alcuni upgrades mi vengono installati dei prodotti che prima non avevo installati.

 

Grazie in anticipo.

Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



--
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: [hidden email]
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

R: R: Upgrade di Plone - portal_setup e plone.app.theming

Lorenzo Maurizi - C.S.I.A. UniMC

Grazie Luca

in effetti sto facendo delle prove di migrazione, quindi non ho problemi a riprendere un backup di Data.fs e blobstorage e ripetere le azioni strettamente necessarie al funzionamento corretto del sito.

Quindi, dopo il riavvio dell'istanza di plone, i passi al momento necessari sono:

1) aggiornamento del sito plone

2) aggiornamento dei prodotti da interfaccia installazione prodotti di Plone (/prefs_install_products_form)

3) in questo caso aggiornamento del solo tinymce da portal_setup - upgrades

tutto il resto, lascio come sta.

 

Tutti i siti plone presenti nell'istanza zope hanno presentato lo stesso problema di TinyMCE, invece un nuovo sito funziona correttamente.

 

Grazie ancora.

Ciao da Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Luca Fabbri
Inviato: martedì 1 luglio 2014 14:10
A: La lista degli italiani appassionati di Plone.
Oggetto: Re: [Plone-IT] R: Upgrade di Plone - portal_setup e plone.app.theming

 

Il portal_setup è un tool di basso livello, non è saggio entrarci e lanciare upgrade senza sapere che cosa comportano. Normalmente (per prodotti fatti "bene") gli upgrade che trovi lì sono tradotti in aggiornamenti di prodotti dalla più comoda interfaccia di Plone.

Se puoi tornare alla versione precedente del tuo sito (da un backup) è meglio, oppure usa gli undo, come hai detto prima.

Per il tuo problema originale: sembrerebbe un qualche tipo di problema di migrazione (l'upgrade di Plone avrebbe dovuto fare quel lavoro al tuo posto) e in quel caso hai fatto probabilmente bene a lanciare l'aggiornamento.

In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo provoca un reset delle impostazioni del prodotto alla configurazione iniziale.

In ogni caso: tutto questo va sempre fatto con attenzione (==backup).

 

 

 

2014-07-01 13:46 GMT+02:00 Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]>:

Altra domanda:

gli upgrades presenti in portal_setup vanno fatti tutti? Qual è la ratio? Ho visto che applicando alcuni upgrades mi vengono installati dei prodotti che prima non avevo installati.

 

Grazie in anticipo.

Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html




--
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: [hidden email]
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

Re: R: R: Upgrade di Plone - portal_setup e plone.app.theming

Vito
In reply to this post by Luca Fabbri-2
Un consiglio poco tecnico, ma più pragmatico-filosofico: 
se non esiste una vera motivazione alla migrazione verso una release maggiore di un portale plone utilizzato&funzionante meglio evitare.
;)

Vito


Il giorno 01 luglio 2014 15:29, Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]> ha scritto:

Grazie Luca

in effetti sto facendo delle prove di migrazione, quindi non ho problemi a riprendere un backup di Data.fs e blobstorage e ripetere le azioni strettamente necessarie al funzionamento corretto del sito.

Quindi, dopo il riavvio dell'istanza di plone, i passi al momento necessari sono:

1) aggiornamento del sito plone

2) aggiornamento dei prodotti da interfaccia installazione prodotti di Plone (/prefs_install_products_form)

3) in questo caso aggiornamento del solo tinymce da portal_setup - upgrades

tutto il resto, lascio come sta.

 

Tutti i siti plone presenti nell'istanza zope hanno presentato lo stesso problema di TinyMCE, invece un nuovo sito funziona correttamente.

 

Grazie ancora.

Ciao da Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Luca Fabbri
Inviato: martedì 1 luglio 2014 14:10


A: La lista degli italiani appassionati di Plone.
Oggetto: Re: [Plone-IT] R: Upgrade di Plone - portal_setup e plone.app.theming

 

Il portal_setup è un tool di basso livello, non è saggio entrarci e lanciare upgrade senza sapere che cosa comportano. Normalmente (per prodotti fatti "bene") gli upgrade che trovi lì sono tradotti in aggiornamenti di prodotti dalla più comoda interfaccia di Plone.

Se puoi tornare alla versione precedente del tuo sito (da un backup) è meglio, oppure usa gli undo, come hai detto prima.

Per il tuo problema originale: sembrerebbe un qualche tipo di problema di migrazione (l'upgrade di Plone avrebbe dovuto fare quel lavoro al tuo posto) e in quel caso hai fatto probabilmente bene a lanciare l'aggiornamento.

In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo provoca un reset delle impostazioni del prodotto alla configurazione iniziale.

In ogni caso: tutto questo va sempre fatto con attenzione (==backup).

 

 

 

2014-07-01 13:46 GMT+02:00 Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]>:

Altra domanda:

gli upgrades presenti in portal_setup vanno fatti tutti? Qual è la ratio? Ho visto che applicando alcuni upgrades mi vengono installati dei prodotti che prima non avevo installati.

 

Grazie in anticipo.

Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html




--
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: [hidden email]
Web Site: http://www.redturtle.it/
Phone: <a href="tel:%2B39%200532%201915958" value="+3905321915958" target="_blank">+39 0532 1915958
Fax: <a href="tel:%2B39%200532%20287070" value="+390532287070" target="_blank">+39 0532 287070


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



--
Vito Falco
Designer & Front-end developer | Plone consultant | Freelance 
Bari, IT
tel +39 3346330137 | skype vito80ba | twitter vito80ba

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

Re: R: R: Upgrade di Plone - portal_setup e plone.app.theming

faber
Considerazione banale: non mi è mai capitata una migrazione Plone andata liscia al primo colpo.
Non oso immaginare cosa voglia dire passare a Plone 5......


Il giorno 01 luglio 2014 15:32, Vito Falco <[hidden email]> ha scritto:
Un consiglio poco tecnico, ma più pragmatico-filosofico: 
se non esiste una vera motivazione alla migrazione verso una release maggiore di un portale plone utilizzato&funzionante meglio evitare.
;)

Vito


Il giorno 01 luglio 2014 15:29, Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]> ha scritto:

Grazie Luca

in effetti sto facendo delle prove di migrazione, quindi non ho problemi a riprendere un backup di Data.fs e blobstorage e ripetere le azioni strettamente necessarie al funzionamento corretto del sito.

Quindi, dopo il riavvio dell'istanza di plone, i passi al momento necessari sono:

1) aggiornamento del sito plone

2) aggiornamento dei prodotti da interfaccia installazione prodotti di Plone (/prefs_install_products_form)

3) in questo caso aggiornamento del solo tinymce da portal_setup - upgrades

tutto il resto, lascio come sta.

 

Tutti i siti plone presenti nell'istanza zope hanno presentato lo stesso problema di TinyMCE, invece un nuovo sito funziona correttamente.

 

Grazie ancora.

Ciao da Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Luca Fabbri
Inviato: martedì 1 luglio 2014 14:10


A: La lista degli italiani appassionati di Plone.
Oggetto: Re: [Plone-IT] R: Upgrade di Plone - portal_setup e plone.app.theming

 

Il portal_setup è un tool di basso livello, non è saggio entrarci e lanciare upgrade senza sapere che cosa comportano. Normalmente (per prodotti fatti "bene") gli upgrade che trovi lì sono tradotti in aggiornamenti di prodotti dalla più comoda interfaccia di Plone.

Se puoi tornare alla versione precedente del tuo sito (da un backup) è meglio, oppure usa gli undo, come hai detto prima.

Per il tuo problema originale: sembrerebbe un qualche tipo di problema di migrazione (l'upgrade di Plone avrebbe dovuto fare quel lavoro al tuo posto) e in quel caso hai fatto probabilmente bene a lanciare l'aggiornamento.

In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo provoca un reset delle impostazioni del prodotto alla configurazione iniziale.

In ogni caso: tutto questo va sempre fatto con attenzione (==backup).

 

 

 

2014-07-01 13:46 GMT+02:00 Lorenzo Maurizi - C.S.I.A. UniMC <[hidden email]>:

Altra domanda:

gli upgrades presenti in portal_setup vanno fatti tutti? Qual è la ratio? Ho visto che applicando alcuni upgrades mi vengono installati dei prodotti che prima non avevo installati.

 

Grazie in anticipo.

Lorenzo

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Lorenzo Maurizi - C.S.I.A. UniMC
Inviato: martedì 1 luglio 2014 13:26
A: 'La lista degli italiani appassionati di Plone.'
Oggetto: [Plone-IT] Upgrade di Plone - portal_setup e plone.app.theming

 

Salve a tutti,

mi sto cimentando da "niubbo" nell'aggiornamento di Plone da un nostro portale 4.2.0 all'ultima 4.3.3.

 

Dopo aver aggiornato il buildout, i prodotti, ecc. ecc., ho avviato plone, e effettuato la migrazione dei siti.

Successivamente, dato che non mi veniva caricato TinyMCE, ho scoperto il mondo delle Upgrades del portal_setup!!!

 

Ho quindi effettuato vari aggiornamenti presenti sul questa interfaccia, uno ad uno, fino ad incontrare il profilo

plone.app.theming:default

Sono presenti due passi:

 

The profile "plone.app.theming:default" is currently upgraded to version unknown.

The filesystem version for the "plone.app.theming:default" profile is currently 1001.

Inizio modulo

Available upgrades:

Update registry

(all 1000)

Combine Theming control panels

(1000 1001)

 

Questi passi sono presenti anche in un portale con plone 4.3.2 "nativo".

Se faccio il primo passo, tutto OK.

Se faccio il secondo passo, l'icona di "camicia" Temi di @@overview-controlpanel (che punta a @@skins-controlpanel) viene sostituita dalla icona "puzzle" denominata "Tema" (al singolare) che punta a @@theming-controlpanel; a questo punto, cliccando su tale icona, ottengo un errore:

 

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish

  Module ZPublisher.mapply, line 77, in mapply

  Module ZPublisher.Publish, line 48, in call_object

  Module plone.app.theming.browser.controlpanel, line 50, in __call__

  Module plone.app.theming.browser.controlpanel, line 72, in update

  Module plone.app.theming.browser.controlpanel, line 56, in _setup

  Module plone.app.theming.utils, line 371, in getZODBThemes

  Module plone.resource.manifest, line 220, in getZODBResources

  Module zope.component._api, line 169, in getUtility

ComponentLookupError: (<InterfaceClass plone.resource.interfaces.IResourceDirectory>, 'persistent')

 

Perché succede questo?

Grazie in anticipo.

 

Ciao da Lorenzo - uniMC


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html




--
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: [hidden email]
Web Site: http://www.redturtle.it/
Phone: <a href="tel:%2B39%200532%201915958" value="+3905321915958" target="_blank">+39 0532 1915958
Fax: <a href="tel:%2B39%200532%20287070" value="+390532287070" target="_blank">+39 0532 287070




--
Vito Falco
Designer & Front-end developer | Plone consultant | Freelance 
Bari, IT
tel <a href="tel:%2B39%203346330137" value="+393346330137" target="_blank">+39 3346330137 | skype vito80ba | twitter vito80ba

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



--
Fabrizio
--------------------
Non inviato da IPhone

"Life is what happens to you while you're busy making other plans" - J. Lennon

“If you think education is expensive, try ignorance” - D. Bok

Life is like a game of cards. The hand you are dealt is determinism; the way you play it is free will - Jawaharlal Nehru

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

Re: R: Upgrade di Plone - portal_setup e plone.app.theming

doliveri
This post was updated on .
In reply to this post by Luca Fabbri-2
"In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo provoca un reset delle impostazioni del prodotto alla configurazione iniziale"

Ho un problema anche, praticamente mi compare due volte il link "TinyMCE Visual Editor" sul Configurazioni del sito di Plone e cliccandoci mi da errore..
Vorrei reinstallarlo o come dici tu fare il reset, come posso fare?

Ho appena visto che su portal_javascript mancano i file:

jquery.tinymce.js
tiny_mce_gzip.js
(resource not found or not accessible)
Reply | Threaded
Open this post in threaded view
|

Re: R: Upgrade di Plone - portal_setup e plone.app.theming

Luca Fabbri-2
2015-05-20 18:05 GMT+02:00 doliveri <[hidden email]>:
> "In altri casi usare l'import step di TinyMCE potrebbe aiutare: questo
> provoca un reset delle impostazioni del prodotto alla configurazione
> iniziale."
>
> Ho un problema anche, praticamente mi compare due volte il link "TinyMCE
> Visual Editor" sul Configurazioni del sito di Plone.
> Vorrei reinstallarlo o come dici tu fare il reset, come posso fare?
>

Gli elementi che ti compaiono nel pannello di controllo Plone possono
essere manipolati da ZMI, dal tool portal_controlpanel




--
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: [hidden email]
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html