[Problemas servidor Plone ´IDG´] [4 Anexos]

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Problemas servidor Plone ´IDG´] [4 Anexos]

Alexandre Chagas
Bom dia pessoal, aos feras de infraestrutura ;)

Gostaria de saber a opinião/ajuda de vocês quanto a um problema num de
nossos servidores:

sou Alexandre e trabalho na ANA - Agência Nacional de Águas ;)

O servidor em questão, é do portal principal da Agência.

- Servidor Linux"Debian" com cerca de 140 GB de disco e 16 GB de RAM,
- Instalação Plone (IDG) zeo com duas instâncias, basicamente não há outros
serviços instalados neste servidor.

* Um breve resumo quanto a instalação: (instalei o Plone puro 4.3..11) e
depois, via buildout instalei o brasil.gov.portal) pronto, simples e
rápido, no ar há cerca de dois anos. funcionando bem até o momento.

Mensagem da nossa infraestrutura

>>>>>
Prezados,
Analisando os indicadores do servidor SAPUCAÍ (Plone Produção – site ANA),
notei que há  aumento constante do consumo de memória, independente do
horário , logo o problema de estouro não tem relação com picos de consultas
ou usuários no site , que varia em 24 horas. Além disto nota-se um aumento
repentino do consumo entre 18:00 e 18:14 do dia 20/07. (Imagens em anexo).
<<<<<

Eu, quanto à nossa infra.

- Um fator que sempre questionei foi e é, a falta de um servidor de CACHE
instalado, a resposta da infra é que não precisa porque nosso portal não é
tão grande assim.

- Tento argumentar que por falta de cache, a busca no banco é constante,
causando um consumo excessivo de memória. Dou-me com vencido! :(

Então, possuímos esse servidor com haproxy, mas não há cacheamento sendo
executado!

Analisei os logs e não identifiquei nada de anormal,
exceto no event.log de uma das instâncias, (anexo >
print-server-log.jpg) onde identifiquei um evento estranho mais próximo ao
horário indicado pela infra (entre 18:00 e 18:14), no logo indica 18:40.
Por isso não acredito que este foi a causa.

Não sei se ajuda, mas segue anexo os prints enviados pela infra.

Gostaria de saber a opinião de vocês quanto a necessidade de utilização de
um servidor. E como proceder com estes aumentos repentinos de uso de
memória.

Desde já, agradecido por qualquer ajuda ;)

--
*Alexandre Chagas*