Pannello workflow corrotto

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Pannello workflow corrotto

ntarantino
salve, da qualche giorno la pagina
http://miosito/portale/portal_workflow/manage_workspace
mi restituisce solo una serie di segnacci tipo

������
con Firefox
e pagina bianca con IE.

ho provato ad aggiornare a Plone 4.2.5 (dalla 4.2.rc2) ma l'errore persiste.

Qualche idea?





_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

Vito
Mai vista una cosa del genere.

Una volta che sei sulla pagina apri il "codice sorgente" e vedi se c'è qualche stringa corrotta, scritta e metà o roba del genere.

Vito

Il giorno 27 ottobre 2016 10:50, Natale Tarantino <[hidden email]> ha scritto:
salve, da qualche giorno la pagina http://miosito/portale/portal_workflow/manage_workspace
mi restituisce solo una serie di segnacci tipo

������
con Firefox
e pagina bianca con IE.

ho provato ad aggiornare a Plone 4.2.5 (dalla 4.2.rc2) ma l'errore persiste.

Qualche idea?





_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



--
Vito Falco
Designer & Front-end developer | Freelance
Bari, IT

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

alepisa
In reply to this post by ntarantino
2016-10-27 10:50 GMT+02:00 Natale Tarantino <[hidden email]>:

> salve, da qualche giorno la pagina
> http://miosito/portale/portal_workflow/manage_workspace
> mi restituisce solo una serie di segnacci tipo
>
> ������
> con Firefox
> e pagina bianca con IE.
>
> ho provato ad aggiornare a Plone 4.2.5 (dalla 4.2.rc2) ma l'errore persiste.
>
> Qualche idea?
>

Molto bello e fantasioso!
Controlla anche gli header che ti vengono restituiti.

Qualcosa tipo:

curl -sI https://plone.org

dovrebbe mostrarteli.
Hai qualche proxy davanti (varnish, haproxy, pound)?
Che succede se lo salti?

In bocca al luppolo!
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

ntarantino
curl -sI http://10.10.200.21:8080/portale
HTTP/1.1 200 OK
Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
Date: Thu, 27 Oct 2016 10:03:24 GMT
Last-Modified: Thu, 27 Oct 2016 10:03:24 GMT
Content-Length: 76
Connection: close
Accept-Ranges: none
Date: Thu, 27 Oct 2016 10:03:24 GMT
Content-Location: http://10.10.200.21:8080/portale/
Content-Type: text/html
e mi sembra vada bene:-)

  curl -sI http://10.10.200.21:8080/portale/portal_workflows
HTTP/1.1 404 Not Found
Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
Date: Thu, 27 Oct 2016 10:04:17 GMT
Content-Length: 0
X-Ua-Compatible: IE=edge,chrome=1
Expires: Sat, 1 Jan 2000 00:00:00 GMT
X-Ksscommands: <?xml version="1.0"?> <kukit
xmlns="http://www.kukit.org/commands/1.1"> <commands> <command
name="error">          <param name="type">system</param>              
<param name="message">NotFound: The requested resource does not
exist.</param>  </command> </commands> </kukit>
Accept-Ranges: none
Content-Language: it
Content-Type: text/html;charset=utf-8
Non sono autenticato e quindi non viene tornata la pagina

Davanti plone c'è apache (rewrite rule 80->8080 ma funzionava)
e fra l'altro sto facendo i test con apache spento.

Ho anche provato ad eliminare i .pyc da DCWorkflow e PlacefullWF per
fare rigenerare il bytecode.




Il 27/10/2016 11:29, Alessandro Pisa ha scritto:

> 2016-10-27 10:50 GMT+02:00 Natale Tarantino <[hidden email]>:
>> salve, da qualche giorno la pagina
>> http://miosito/portale/portal_workflow/manage_workspace
>> mi restituisce solo una serie di segnacci tipo
>>
>> ������
>> con Firefox
>> e pagina bianca con IE.
>>
>> ho provato ad aggiornare a Plone 4.2.5 (dalla 4.2.rc2) ma l'errore persiste.
>>
>> Qualche idea?
>>
> Molto bello e fantasioso!
> Controlla anche gli header che ti vengono restituiti.
>
> Qualcosa tipo:
>
> curl -sI https://plone.org
>
> dovrebbe mostrarteli.
> Hai qualche proxy davanti (varnish, haproxy, pound)?
> Che succede se lo salti?
>
> In bocca al luppolo!


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

alepisa
2016-10-27 12:20 GMT+02:00 Natale Tarantino <[hidden email]>:
> HTTP/1.1 404 Not Found

Ti dice not found, anche perche' l'URL e' sbagliata...

L'URL giusta e' http://localhost:8080/Plone/portal_workflow/manage_overview

Inoltre devi passare i cookie.
Qualcosa tipo

curl -sI 'http://localhost:8080/Plone/portal_workflow/manage_overview'
-H 'Cookie: __ac="..."'

Per trovare la stringa corretta apri il tab network del debugger di
chrome o firefox -> seleziona la richiesta a quell'URL -> tasto dx ->
copy as curl.
Vedi:

- http://lornajane.net/posts/2013/chrome-feature-copy-as-curl
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

ntarantino
Si impara sempre 'copia come curl' non l'avevo mai vista:-[

la risposta
HTTP/1.1 200 OK
Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
Date: Thu, 27 Oct 2016 10:48:07 GMT
Content-Length: 414
Content-Type: text/plain; charset=utf-8


Il 27/10/2016 12:29, Alessandro Pisa ha scritto:

> 2016-10-27 12:20 GMT+02:00 Natale Tarantino <[hidden email]>:
>> HTTP/1.1 404 Not Found
> Ti dice not found, anche perche' l'URL e' sbagliata...
>
> L'URL giusta e' http://localhost:8080/Plone/portal_workflow/manage_overview
>
> Inoltre devi passare i cookie.
> Qualcosa tipo
>
> curl -sI 'http://localhost:8080/Plone/portal_workflow/manage_overview'
> -H 'Cookie: __ac="..."'
>
> Per trovare la stringa corretta apri il tab network del debugger di
> chrome o firefox -> seleziona la richiesta a quell'URL -> tasto dx ->
> copy as curl.
> Vedi:
>
> - http://lornajane.net/posts/2013/chrome-feature-copy-as-curl


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

alepisa
2016-10-27 12:48 GMT+02:00 Natale Tarantino <[hidden email]>:
> Si impara sempre 'copia come curl' non l'avevo mai vista:-[
>
> la risposta
> HTTP/1.1 200 OK
> Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
> Date: Thu, 27 Oct 2016 10:48:07 GMT
> Content-Length: 414
> Content-Type: text/plain; charset=utf-8
>

Strano la risposta e' molto "corta", content length dovrebbe essere
qualcosa attorno a 20k.
Cosa ti torna se togli "-sI"?
In teoria dovrebbe tornarti il sorgente della pagina.

Altra cosa, non ho sotto mano un 4.2, ma sun plone 5 manage_workspace
e' una redirect a manage_selectWorkflows.

Ciao.
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

ntarantino
senza -sI non ritorna proprio nulla

sto controllando ora gli addon con un sito praticamente gemello (è nato
4.2.5 non aggiornato come qs) per vedere se ci sono differenze di versioni

Ciao
Il 27/10/2016 12:59, Alessandro Pisa ha scritto:

> 2016-10-27 12:48 GMT+02:00 Natale Tarantino <[hidden email]>:
>> Si impara sempre 'copia come curl' non l'avevo mai vista:-[
>>
>> la risposta
>> HTTP/1.1 200 OK
>> Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
>> Date: Thu, 27 Oct 2016 10:48:07 GMT
>> Content-Length: 414
>> Content-Type: text/plain; charset=utf-8
>>
> Strano la risposta e' molto "corta", content length dovrebbe essere
> qualcosa attorno a 20k.
> Cosa ti torna se togli "-sI"?
> In teoria dovrebbe tornarti il sorgente della pagina.
>
> Altra cosa, non ho sotto mano un 4.2, ma sun plone 5 manage_workspace
> e' una redirect a manage_selectWorkflows.
>
> Ciao.


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

alepisa
2016-10-27 13:07 GMT+02:00 Natale Tarantino <[hidden email]>:
> senza -sI non ritorna proprio nulla
>

Sicuro di non aver bisticciato con i flag di curl?
Qualcosa dovrebbe tornarti...

Ciao
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

ntarantino
confermo senza -sI non ritorna nulla.
con -sI su manage_workspace ritorna:

HTTP/1.1 302 Moved Temporarily
Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
Date: Thu, 27 Oct 2016 13:16:56 GMT
Bobo-Exception-Line: 89
Bobo-Exception-File: Management.py
Bobo-Exception-Type: <class 'zExceptions.Redirect'>
Bobo-Exception-Value: See the server error log for details
Location:
http://10.10.200.21:8080/portale/portal_workflow/manage_selectWorkflows
Content-Length: 0


In compenso se cerco la pagina portal_workflow/manage
vedo la lista dei wf
?
Il mistero s'infittisce
Ciao



Il 27/10/2016 14:22, Alessandro Pisa ha scritto:
> 2016-10-27 13:07 GMT+02:00 Natale Tarantino <[hidden email]>:
>> senza -sI non ritorna proprio nulla
>>
> Sicuro di non aver bisticciato con i flag di curl?
> Qualcosa dovrebbe tornarti...
>
> Ciao


_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pannello workflow corrotto

alepisa
On 27 October 2016 at 15:18, Natale Tarantino
<[hidden email]> wrote:
> confermo senza -sI non ritorna nulla.

Perche' e' una redirect...

> con -sI su manage_workspace ritorna:
>
> HTTP/1.1 302 Moved Temporarily
> Server: Zope/(2.13.19, python 2.7.3, linux2) ZServer/1.1
> Date: Thu, 27 Oct 2016 13:16:56 GMT
> Bobo-Exception-Line: 89
> Bobo-Exception-File: Management.py
> Bobo-Exception-Type: <class 'zExceptions.Redirect'>
> Bobo-Exception-Value: See the server error log for details
> Location:
> http://10.10.200.21:8080/portale/portal_workflow/manage_selectWorkflows
> Content-Length: 0
>

Questi sono header diversi da prima ;)
Sembra funzioni tutto bene...anche da me e' una redirect a
manage_selectWorkflows

Adesso il problema e': cosa ti ritorna manage_selectWorkflows? La
vista "worksflows by type"?

Se si' allora funziona tutto lato Plone e il problema e' altrove.

curl non mente.
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Loading...