Erreur de codage

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Erreur de codage

pola31
Bonjour à tous et bonne année 2016, 

J'ai un souci avec une erreur de codage  'ascii' : 'ascii' codec can't decode byte 0xc3 in position 10: ordinal not in range(128) qui fait planter l'affichage d'un diaporama 'Collective caroussel ' (une collection d'actualité).
Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur. Avez vous une idée d'où cela pourrait provenir?





Je rajoute que je ne pythonne pas, merci pour votre aide, 

Paule Dossi 



_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

Encolpe DEGOUTE

Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :

> Bonjour à tous et bonne année 2016,

>

> J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec can't

> decode byte 0xc3 in position 10: ordinal not in range(128) qui fait planter

> l'affichage d'un diaporama 'Collective caroussel ' (une collection

> d'actualité).

> Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur.

> Avez vous une idée d'où cela pourrait provenir?

 

Je suppose que c'est ce produit :

https://plone.org/products/collective.carousel

 

Quelle est la version du carousel ?

Vous pouvez le trouver dans le panneau de configuration des modules.

 

Quelle est l'encodage utilisé par l'utilisateur lançant le service Plone ? fr_FR.UTF-8 ou C

 

$ echo $LANG
fr_FR.UTF-8

En général ce problème viens d'un bug dans le module ou d'un problème de configuration système.

 

Cordialement,

--

Encolpe Degoute

http://encolpe.wordpress.com

http://encolpe.degoute.free.fr

Logiciels libres, hockey sur glace et autres activités cérébrales

 


_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

pola31
Bonjour Encolpe et merci pour votre réponse, 

La version du Carousel est :  Carousel for Plone 1.6.2

Concernant l'encodage utilisé utf-8 est indiqué dans les propriétés de la ZMI, mais je ne suis pas sure que ce soit le bon endroit où regarder...

J'imagine que le souci viendrait plutôt de la configuration du système, j'ai désinstallé et réinstallé plusieurs fois le module et il fonctionne sur un autre site avec les accents. 

Je ne sais vraiment pas où regarder... je suis complètement coincée avec ce souci.

Merci 

Paule Dossi 



Le 4 janvier 2016 à 17:02, Encolpe DEGOUTE <[hidden email]> a écrit :

Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :

> Bonjour à tous et bonne année 2016,

>

> J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec can't

> decode byte 0xc3 in position 10: ordinal not in range(128) qui fait planter

> l'affichage d'un diaporama 'Collective caroussel ' (une collection

> d'actualité).

> Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur.

> Avez vous une idée d'où cela pourrait provenir?

 

Je suppose que c'est ce produit :

https://plone.org/products/collective.carousel

 

Quelle est la version du carousel ?

Vous pouvez le trouver dans le panneau de configuration des modules.

 

Quelle est l'encodage utilisé par l'utilisateur lançant le service Plone ? fr_FR.UTF-8 ou C

 

$ echo $LANG
fr_FR.UTF-8

En général ce problème viens d'un bug dans le module ou d'un problème de configuration système.

 

Cordialement,

--

Encolpe Degoute

http://encolpe.wordpress.com

http://encolpe.degoute.free.fr

Logiciels libres, hockey sur glace et autres activités cérébrales

 


_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr



_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

Encolpe DEGOUTE
Cela ressemble à un problème système dans votre cas.
Avez-vous accès au système d'exploitation du serveur qui héberge le site ?

Il faudrait au minimum essayer de passer à la version 1.7 de collective.carousel.

Encolpe

Le Monday 04 January 2016, 17:09:43 Paule DOSSI a écrit :

> Bonjour Encolpe et merci pour votre réponse,
>
> La version du Carousel est :  Carousel for Plone 1.6.2
>
> Concernant l'encodage utilisé utf-8 est indiqué dans les propriétés de la
> ZMI, mais je ne suis pas sure que ce soit le bon endroit où regarder...
>
> J'imagine que le souci viendrait plutôt de la configuration du système,
> j'ai désinstallé et réinstallé plusieurs fois le module et il fonctionne
> sur un autre site avec les accents.
>
> Je ne sais vraiment pas où regarder... je suis complètement coincée avec ce
> souci.
>
> Merci
>
> Paule Dossi
>
>
>
> Le 4 janvier 2016 à 17:02, Encolpe DEGOUTE <[hidden email]> a
> écrit :
>
> > Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :
> >
> > > Bonjour à tous et bonne année 2016,
> >
> > >
> >
> > > J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec can't
> >
> > > decode byte 0xc3 in position 10: ordinal not in range(128) qui fait
> > planter
> >
> > > l'affichage d'un diaporama 'Collective caroussel ' (une collection
> >
> > > d'actualité).
> >
> > > Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur.
> >
> > > Avez vous une idée d'où cela pourrait provenir?
> >
> >
> >
> > Je suppose que c'est ce produit :
> >
> > https://plone.org/products/collective.carousel
> >
> >
> >
> > Quelle est la version du carousel ?
> >
> > Vous pouvez le trouver dans le panneau de configuration des modules.
> >
> >
> >
> > Quelle est l'encodage utilisé par l'utilisateur lançant le service Plone ?
> > fr_FR.UTF-8 ou C
> >
> >
> >
> > $ echo $LANG
> > fr_FR.UTF-8
> >
> > En général ce problème viens d'un bug dans le module ou d'un problème de
> > configuration système.

--
Encolpe Degoute
http://encolpe.wordpress.com
http://encolpe.degoute.free.fr
Logiciels libres, hockey sur glace et autres activités cérébrales

_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

pola31
Bonjour Encolpe, 

Le système d'exploitation qui héberge le site est :  un serveur Linux Debian Wheezy , je n'ai effectivement pas la main dessus, mais je peux déjà dire à l'administrateur système que le problème viendrait de là.

Je vais de mon côté changer la version du module, 

Je vous remercie pour vos réponses, 

Paule Dossi 



Le 4 janvier 2016 à 19:20, Encolpe DEGOUTE <[hidden email]> a écrit :
Cela ressemble à un problème système dans votre cas.
Avez-vous accès au système d'exploitation du serveur qui héberge le site ?

Il faudrait au minimum essayer de passer à la version 1.7 de collective.carousel.

Encolpe

Le Monday 04 January 2016, 17:09:43 Paule DOSSI a écrit :
> Bonjour Encolpe et merci pour votre réponse,
>
> La version du Carousel est :  Carousel for Plone 1.6.2
>
> Concernant l'encodage utilisé utf-8 est indiqué dans les propriétés de la
> ZMI, mais je ne suis pas sure que ce soit le bon endroit où regarder...
>
> J'imagine que le souci viendrait plutôt de la configuration du système,
> j'ai désinstallé et réinstallé plusieurs fois le module et il fonctionne
> sur un autre site avec les accents.
>
> Je ne sais vraiment pas où regarder... je suis complètement coincée avec ce
> souci.
>
> Merci
>
> Paule Dossi
>
>
>
> Le 4 janvier 2016 à 17:02, Encolpe DEGOUTE <[hidden email]> a
> écrit :
>
> > Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :
> >
> > > Bonjour à tous et bonne année 2016,
> >
> > >
> >
> > > J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec can't
> >
> > > decode byte 0xc3 in position 10: ordinal not in range(128) qui fait
> > planter
> >
> > > l'affichage d'un diaporama 'Collective caroussel ' (une collection
> >
> > > d'actualité).
> >
> > > Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur.
> >
> > > Avez vous une idée d'où cela pourrait provenir?
> >
> >
> >
> > Je suppose que c'est ce produit :
> >
> > https://plone.org/products/collective.carousel
> >
> >
> >
> > Quelle est la version du carousel ?
> >
> > Vous pouvez le trouver dans le panneau de configuration des modules.
> >
> >
> >
> > Quelle est l'encodage utilisé par l'utilisateur lançant le service Plone ?
> > fr_FR.UTF-8 ou C
> >
> >
> >
> > $ echo $LANG
> > fr_FR.UTF-8
> >
> > En général ce problème viens d'un bug dans le module ou d'un problème de
> > configuration système.

--
Encolpe Degoute
http://encolpe.wordpress.com
http://encolpe.degoute.free.fr
Logiciels libres, hockey sur glace et autres activités cérébrales

_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr


_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

pola31
Bonjour,

J'ai installé la version 1.7 de collective.carousel et j'ai toujours la même erreur lorsque le titre de l'actualité comporte des accents. : 

Valeur de l'erreur
    'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in range(128) 

Sans les accents les actualités apparaissent les unes en dessous des autres et non sous forme de diaporama.

Si cela ressemble à un problème système, quel problème pourrait-il être ? 

Je vous remercie vivement pour votre aide !

Paule Dossi 



Le 5 janvier 2016 à 10:24, Paule DOSSI <[hidden email]> a écrit :
Bonjour Encolpe, 

Le système d'exploitation qui héberge le site est :  un serveur Linux Debian Wheezy , je n'ai effectivement pas la main dessus, mais je peux déjà dire à l'administrateur système que le problème viendrait de là.

Je vais de mon côté changer la version du module, 

Je vous remercie pour vos réponses, 

Paule Dossi 



Le 4 janvier 2016 à 19:20, Encolpe DEGOUTE <[hidden email]> a écrit :
Cela ressemble à un problème système dans votre cas.
Avez-vous accès au système d'exploitation du serveur qui héberge le site ?

Il faudrait au minimum essayer de passer à la version 1.7 de collective.carousel.

Encolpe

Le Monday 04 January 2016, 17:09:43 Paule DOSSI a écrit :
> Bonjour Encolpe et merci pour votre réponse,
>
> La version du Carousel est :  Carousel for Plone 1.6.2
>
> Concernant l'encodage utilisé utf-8 est indiqué dans les propriétés de la
> ZMI, mais je ne suis pas sure que ce soit le bon endroit où regarder...
>
> J'imagine que le souci viendrait plutôt de la configuration du système,
> j'ai désinstallé et réinstallé plusieurs fois le module et il fonctionne
> sur un autre site avec les accents.
>
> Je ne sais vraiment pas où regarder... je suis complètement coincée avec ce
> souci.
>
> Merci
>
> Paule Dossi
>
>
>
> Le 4 janvier 2016 à 17:02, Encolpe DEGOUTE <[hidden email]> a
> écrit :
>
> > Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :
> >
> > > Bonjour à tous et bonne année 2016,
> >
> > >
> >
> > > J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec can't
> >
> > > decode byte 0xc3 in position 10: ordinal not in range(128) qui fait
> > planter
> >
> > > l'affichage d'un diaporama 'Collective caroussel ' (une collection
> >
> > > d'actualité).
> >
> > > Si je retire les accents du titre de l'actualité, je n'ai pus d'erreur.
> >
> > > Avez vous une idée d'où cela pourrait provenir?
> >
> >
> >
> > Je suppose que c'est ce produit :
> >
> > https://plone.org/products/collective.carousel
> >
> >
> >
> > Quelle est la version du carousel ?
> >
> > Vous pouvez le trouver dans le panneau de configuration des modules.
> >
> >
> >
> > Quelle est l'encodage utilisé par l'utilisateur lançant le service Plone ?
> > fr_FR.UTF-8 ou C
> >
> >
> >
> > $ echo $LANG
> > fr_FR.UTF-8
> >
> > En général ce problème viens d'un bug dans le module ou d'un problème de
> > configuration système.

--
Encolpe Degoute
http://encolpe.wordpress.com
http://encolpe.degoute.free.fr
Logiciels libres, hockey sur glace et autres activités cérébrales

_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr



_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Erreur de codage

Gilles Lenfant-2
Bonjour Paule,

Je vous suggère de signaler en anglais votre souci dans le tracker de
collective.carousel [1] en y mettant un maximum de détails :

- Le traceback Python complet de l'erreur

- Un ou plusieurs exemples de scénarios pour reproduire l'apparition de l'erreur

- Un dump complet de votre configuration (copier/coller depuis le
panneau de configuration de Plone)

(peut-être une piste) : demandez à un opérateur ayant un accès SSH sur
vos serveurs de comparer les variables d'environnement LC_AL, LANG et
LANGUAGE des processus qui exécutent vos instances Zope/Plone.

[1] https://github.com/collective/collective.carousel/issues

Le 7 janvier 2016 à 16:34, Paule DOSSI <[hidden email]> a écrit :

> Bonjour,
>
> J'ai installé la version 1.7 de collective.carousel et j'ai toujours la même
> erreur lorsque le titre de l'actualité comporte des accents. :
>
> Valeur de l'erreur
>     'ascii' codec can't decode byte 0xc3 in position 18: ordinal not in
> range(128)
>
> Sans les accents les actualités apparaissent les unes en dessous des autres
> et non sous forme de diaporama.
>
> Si cela ressemble à un problème système, quel problème pourrait-il être ?
>
> Je vous remercie vivement pour votre aide !
>
> Paule Dossi
>
>
>
> Le 5 janvier 2016 à 10:24, Paule DOSSI <[hidden email]> a écrit :
>>
>> Bonjour Encolpe,
>>
>> Le système d'exploitation qui héberge le site est :  un serveur Linux
>> Debian Wheezy , je n'ai effectivement pas la main dessus, mais je peux déjà
>> dire à l'administrateur système que le problème viendrait de là.
>>
>> Je vais de mon côté changer la version du module,
>>
>> Je vous remercie pour vos réponses,
>>
>> Paule Dossi
>>
>>
>>
>> Le 4 janvier 2016 à 19:20, Encolpe DEGOUTE <[hidden email]> a
>> écrit :
>>>
>>> Cela ressemble à un problème système dans votre cas.
>>> Avez-vous accès au système d'exploitation du serveur qui héberge le site
>>> ?
>>>
>>> Il faudrait au minimum essayer de passer à la version 1.7 de
>>> collective.carousel.
>>>
>>> Encolpe
>>>
>>> Le Monday 04 January 2016, 17:09:43 Paule DOSSI a écrit :
>>> > Bonjour Encolpe et merci pour votre réponse,
>>> >
>>> > La version du Carousel est :  Carousel for Plone 1.6.2
>>> >
>>> > Concernant l'encodage utilisé utf-8 est indiqué dans les propriétés de
>>> > la
>>> > ZMI, mais je ne suis pas sure que ce soit le bon endroit où regarder...
>>> >
>>> > J'imagine que le souci viendrait plutôt de la configuration du système,
>>> > j'ai désinstallé et réinstallé plusieurs fois le module et il
>>> > fonctionne
>>> > sur un autre site avec les accents.
>>> >
>>> > Je ne sais vraiment pas où regarder... je suis complètement coincée
>>> > avec ce
>>> > souci.
>>> >
>>> > Merci
>>> >
>>> > Paule Dossi
>>> >
>>> >
>>> >
>>> > Le 4 janvier 2016 à 17:02, Encolpe DEGOUTE <[hidden email]> a
>>> > écrit :
>>> >
>>> > > Le Monday 04 January 2016, 16:53:06 Paule DOSSI a écrit :
>>> > >
>>> > > > Bonjour à tous et bonne année 2016,
>>> > >
>>> > > >
>>> > >
>>> > > > J'ai un souci avec une erreur de codage 'ascii' : 'ascii' codec
>>> > > > can't
>>> > >
>>> > > > decode byte 0xc3 in position 10: ordinal not in range(128) qui fait
>>> > > planter
>>> > >
>>> > > > l'affichage d'un diaporama 'Collective caroussel ' (une collection
>>> > >
>>> > > > d'actualité).
>>> > >
>>> > > > Si je retire les accents du titre de l'actualité, je n'ai pus
>>> > > > d'erreur.
>>> > >
>>> > > > Avez vous une idée d'où cela pourrait provenir?
>>> > >
>>> > >
>>> > >
>>> > > Je suppose que c'est ce produit :
>>> > >
>>> > > https://plone.org/products/collective.carousel
>>> > >
>>> > >
>>> > >
>>> > > Quelle est la version du carousel ?
>>> > >
>>> > > Vous pouvez le trouver dans le panneau de configuration des modules.
>>> > >
>>> > >
>>> > >
>>> > > Quelle est l'encodage utilisé par l'utilisateur lançant le service
>>> > > Plone ?
>>> > > fr_FR.UTF-8 ou C
>>> > >
>>> > >
>>> > >
>>> > > $ echo $LANG
>>> > > fr_FR.UTF-8
>>> > >
>>> > > En général ce problème viens d'un bug dans le module ou d'un problème
>>> > > de
>>> > > configuration système.
>>>
>>> --
>>> Encolpe Degoute
>>> http://encolpe.wordpress.com
>>> http://encolpe.degoute.free.fr
>>> Logiciels libres, hockey sur glace et autres activités cérébrales
>>>
>>> _______________________________________________
>>> Plone-FR mailing list
>>> [hidden email]
>>> https://lists.plone.org/mailman/listinfo/plone-plone-fr
>>
>>
>
>
> _______________________________________________
> Plone-FR mailing list
> [hidden email]
> https://lists.plone.org/mailman/listinfo/plone-plone-fr
>
_______________________________________________
Plone-FR mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-fr
Loading...