Come faccio ad installare Plone 4.3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Come faccio ad installare Plone 4.3

Giampiero Lago
Salve Ragazzi,

sto cercando disperatamente di installare Plone 4.3 ma l'operazione mi
risulta impossibile
io segue questa procedura:

sudo apt-get install python-virtualenv
virtualenv plone-virtualenv
source plone-virtualenv/bin/activate
easy_install "ZopeSkel<2.99"
paster create -t plone4_buildout myplonefolder
seleziono 4.3
python2.6 bootstrap.py

una volta che lancio il comando python bootstrap.py si blocca sempre su
questo punto:

Traceback (most recent call last):
   File "bootstrap.py", line 70, in <module>
     exec urllib2.urlopen(setup_url).read() in ez
   File "/usr/lib64/python2.6/urllib2.py", line 126, in urlopen
     return _opener.open(url, data, timeout)
   File "/usr/lib64/python2.6/urllib2.py", line 397, in open
     response = meth(req, response)
   File "/usr/lib64/python2.6/urllib2.py", line 510, in http_response
     'http', request, response, code, msg, hdrs)
   File "/usr/lib64/python2.6/urllib2.py", line 429, in error
     result = self._call_chain(*args)
   File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain
     result = func(*args)
   File "/usr/lib64/python2.6/urllib2.py", line 616, in http_error_302
     return self.parent.open(new, timeout=req.timeout)
   File "/usr/lib64/python2.6/urllib2.py", line 397, in open
     response = meth(req, response)
   File "/usr/lib64/python2.6/urllib2.py", line 510, in http_response
     'http', request, response, code, msg, hdrs)
   File "/usr/lib64/python2.6/urllib2.py", line 435, in error
     return self._call_chain(*args)
   File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain
     result = func(*args)
   File "/usr/lib64/python2.6/urllib2.py", line 518, in http_error_default
     raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found

ed effettivamente aprendo il file bootstrap.py lui cerca di scaricare
distribute_setup.py dal sito

http://python-distribute.org/distribute_setup.py

che non esiste più; a questo punto ho modificato bootstrap.py cambiando
il metodo da distribute a setuptools
modificando il valore:

USE_DISTRIBUTE = False

in bootstrap.py ma rilanciando il comando le cose non è che vadano
meglio infatti mo compare:

Downloading
http://pypi.python.org/packages/2.7/s/setuptools/setuptools-0.6c11-py2.7.egg
Traceback (most recent call last):
   File "bootstrap.py", line 75, in <module>
     ez['use_setuptools'](to_dir=tmpeggs, download_delay=0)
   File "<string>", line 103, in use_setuptools
   File "<string>", line 97, in do_download
   File "<string>", line 158, in download_setuptools
   File "/usr/lib/python2.7/urllib2.py", line 127, in urlopen
     return _opener.open(url, data, timeout)
   File "/usr/lib/python2.7/urllib2.py", line 410, in open
     response = meth(req, response)
   File "/usr/lib/python2.7/urllib2.py", line 523, in http_response
     'http', request, response, code, msg, hdrs)
   File "/usr/lib/python2.7/urllib2.py", line 448, in error
     return self._call_chain(*args)
   File "/usr/lib/python2.7/urllib2.py", line 382, in _call_chain
     result = func(*args)
   File "/usr/lib/python2.7/urllib2.py", line 531, in http_error_default
     raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 403: SSL is required

il computer in questione è una CentOS 6.9

Grazie a tutti per l'aiuto
Giampiero

--
Giampiero Lago
Web Area Manager - IT Core
TIGEM (Telethon Institute of Genetics and Medicine)
Via Campi Flegrei, 34
80078 - POZZUOLI (NA)

Direct Phone: +39 081 19230637
Secretariat Phone: +39 081 19230600
Fax: +39 081 19230651
E-mail: [hidden email]
Website: http://www.tigem.it

_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
Reply | Threaded
Open this post in threaded view
|

Re: Come faccio ad installare Plone 4.3

alepisa
2017-12-07 16:17 GMT+01:00 Giampiero Lago <[hidden email]>:

> Salve Ragazzi,
>
> sto cercando disperatamente di installare Plone 4.3 ma l'operazione mi
> risulta impossibile
> io segue questa procedura:
>
> sudo apt-get install python-virtualenv
> virtualenv plone-virtualenv
> source plone-virtualenv/bin/activate
> easy_install "ZopeSkel<2.99"
> paster create -t plone4_buildout myplonefolder
> seleziono 4.3
> python2.6 bootstrap.py
>

Non riesci ad usare Python 2.7?

virtualenv plone-virtualenv -p python 2.7

Puoi provare a sostituire python2.6 bootstrap.py con ./bin/pip install
zc.buildout.
Se conosci le versioni di zc.buildout e setuptools da installare e' meglio.

Fatto questo dovresti avere a disposizione lo script bin/buildout
Lancialo. Probabilmente fallira' perche' le versioni di zc.buildout e
setuptools non sono corrette.

Ma poi ci guardiamo...
--
@ale_pisa - http://ale-rt.github.io - http://alepisa.blogspot.com -
https://it.linkedin.com/in/apisa
_______________________________________________
Plone-IT mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-plone-it
http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html