AttributeError: @@plone

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

AttributeError: @@plone

Zanotti Michele
Ciao a tutti,
Sto provando nel mio ambiente di test Plone 2.5.3 (zope 2.9.7 su
windows). Oggi facendo l'update di un profdotto (filesystemstorage) ho
avuto un:

AttributeError: @@plone (Also, the following error occurred while
attempting to render the standard error message, please see the event
log for full details: @@plone)

Da quello che so @@ dovrebbe essere una specie di abbreviazione nelle
view di zope 3, ma quest'errore mi lascia perplesso. Qualcuno sa darmi
qualche indicazione? Di seguito il traceback.
Grazie a tutti
Michele

2007-06-04T15:08:48 ERROR root Exception while rendering an error
message
Traceback (most recent call last):
  File "C:\Zope\2.9.7\Zope\lib\python\OFS\SimpleItem.py", line 223, in
raise_standardErrorMessage
    v = s(**kwargs)
  File "C:\Zope\Instance\2.9.7\Products\CMFCore\FSPythonScript.py", line
108, in __call__
    return Script.__call__(self, *args, **kw)
  File "C:\Zope\2.9.7\Zope\lib\python\Shared\DC\Scripts\Bindings.py",
line 311, in __call__
    return self._bindAndExec(args, kw, None)
  File "C:\Zope\2.9.7\Zope\lib\python\Shared\DC\Scripts\Bindings.py",
line 348, in _bindAndExec
    return self._exec(bound_data, args, kw)
  File "C:\Zope\Instance\2.9.7\Products\CMFCore\FSPythonScript.py", line
164, in _exec
    result = f(*args, **kw)
  File "Script (Python)", line 25, in standard_error_message
  File "C:\Zope\2.9.7\Zope\lib\python\Shared\DC\Scripts\Bindings.py",
line 311, in __call__
    return self._bindAndExec(args, kw, None)
  File "C:\Zope\2.9.7\Zope\lib\python\Shared\DC\Scripts\Bindings.py",
line 348, in _bindAndExec
    return self._exec(bound_data, args, kw)
  File "C:\Zope\Instance\2.9.7\Products\CMFCore\FSPageTemplate.py", line
195, in _exec
    result = self.pt_render(extra_context=bound_names)
  File "C:\Zope\Instance\2.9.7\Products\CMFCore\FSPageTemplate.py", line
134, in pt_render
    result = FSPageTemplate.inheritedAttribute('pt_render')(
  File
"C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\PageTemplate.py",
line 104, in pt_render
    tal=not source, strictinsert=0)()
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 238,
in __call__
    self.interpret(self.program)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 281,
in interpret
    handlers[opcode](self, args)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 749,
in do_useMacro
    self.interpret(macro)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 281,
in interpret
    handlers[opcode](self, args)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 457,
in do_optTag_tal
    self.do_optTag(stuff)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 442,
in do_optTag
    return self.no_tag(start, program)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 437,
in no_tag
    self.interpret(program)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 281,
in interpret
    handlers[opcode](self, args)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 749,
in do_useMacro
    self.interpret(macro)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 281,
in interpret
    handlers[opcode](self, args)
  File "C:\Zope\2.9.7\Zope\lib\python\TAL\TALInterpreter.py", line 511,
in do_setGlobal_tal
    self.engine.setGlobal(name, self.engine.evaluateValue(expr))
  File "C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\TALES.py",
line 221, in evaluate
    return expression(self)
  File
"C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\Expressions.py",
line 185, in __call__
    return self._eval(econtext)
  File
"C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\Expressions.py",
line 173, in _eval
    ob = self._subexprs[-1](econtext)
  File
"C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\Expressions.py",
line 127, in _eval
    ob = restrictedTraverse(ob, path, getSecurityManager())
  File
"C:\Zope\2.9.7\Zope\lib\python\Products\PageTemplates\Expressions.py",
line 286, in restrictedTraverse
    o=t(REQUEST, name)
  File "C:\Zope\Instance\2.9.7\Products\Archetypes\BaseObject.py", line
1140, in __bobo_traverse__
    raise AttributeError(name)
AttributeError: @@plone


_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

Re: AttributeError: @@plone

Fabrizio Reale
Alle lunedì 4 giugno 2007, Zanotti Michele ha scritto:

> Ciao a tutti,
> Sto provando nel mio ambiente di test Plone 2.5.3 (zope 2.9.7 su
> windows). Oggi facendo l'update di un profdotto (filesystemstorage) ho
> avuto un:
>
> AttributeError: @@plone (Also, the following error occurred while
> attempting to render the standard error message, please see the event
> log for full details: @@plone)
>
> Da quello che so @@ dovrebbe essere una specie di abbreviazione nelle
> view di zope 3, ma quest'errore mi lascia perplesso. Qualcuno sa darmi
> qualche indicazione? Di seguito il traceback.
Puoi dettagliare meglio che cosa hai fatto?

Fabrizio



--
Fabrizio Reale                               [hidden email]
Redomino S.r.l.                 Largo Valgioie 14 - 10146 Torino - Italy
Tel: +39 011 7499875 - Fax: +39 011 3716911     http://www.redomino.com/


_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

Re: AttributeError: @@plone

Yuri-11
Fabrizio Reale wrote:

> Alle lunedì 4 giugno 2007, Zanotti Michele ha scritto:
>  
>> Ciao a tutti,
>> Sto provando nel mio ambiente di test Plone 2.5.3 (zope 2.9.7 su
>> windows). Oggi facendo l'update di un profdotto (filesystemstorage) ho
>> avuto un:
>>
>> AttributeError: @@plone (Also, the following error occurred while
>> attempting to render the standard error message, please see the event
>> log for full details: @@plone)
>>
>> Da quello che so @@ dovrebbe essere una specie di abbreviazione nelle
>> view di zope 3, ma quest'errore mi lascia perplesso. Qualcuno sa darmi
>> qualche indicazione? Di seguito il traceback.
>>    
>
> Puoi dettagliare meglio che cosa hai fatto?
>
> Fabrizio
>  

È un bug di plone 2.5.3, credo, che va in confusione quando una
sottodirectory di un prodotto si chiama plone. Ho letto che c'è già la
patch, almeno credo sia questo il problema.

_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

RE: AttributeError: @@plone

Zanotti Michele
In reply to this post by Fabrizio Reale
>
> Puoi dettagliare meglio che cosa hai fatto?
>
> Fabrizio
>
In realtà non molto: venerdì passato ho aggiornato da Plone 2.1.2 a Plone 2.5.3, quindi ho fatto alcuni aggiornamenti (plone ex file alla versione 4) e ho provato ad installare plone4artists tanto per vederlo (ripeto: sono in ambiente di test!), e ho avuto l'errore. Lo ho disinstallato (ho letto che poteva essere causa del problema) e non ho avuto problemi finche' non ho fatto l'update di filesystemstorage. Al che ho eliminato il data.fs e rifatto l'aggiornamento (il mio ambiente di produzione è ancora 2.1.2), ma ora si presenta da subito...
Non ho molti prodotti (essenzialmente utilizzo PloneExFile, attachmentfield 1.3.13, filesystemstorage 2.5.4, ploneglossary 1.3, fckeditor e portaltaxonomy 0.4).
Per quanto riguarda il suggerimento di Yuri: mi sembra che l'unico prodotto con sottodirectory di nome plone sia Kupu...
Grazie
Michele

_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

Re: AttributeError: @@plone

Fabrizio Reale
Alle lunedì 4 giugno 2007, Zanotti Michele ha scritto:

> > Puoi dettagliare meglio che cosa hai fatto?
> >
> > Fabrizio
>
> In realtà non molto: venerdì passato ho aggiornato da Plone 2.1.2 a Plone
> 2.5.3, quindi ho fatto alcuni aggiornamenti (plone ex file alla versione 4)
> e ho provato ad installare plone4artists tanto per vederlo (ripeto: sono in
> ambiente di test!), e ho avuto l'errore. Lo ho disinstallato (ho letto che
> poteva essere causa del problema) e non ho avuto problemi finche' non ho
> fatto l'update di filesystemstorage. Al che ho eliminato il data.fs e
> rifatto l'aggiornamento (il mio ambiente di produzione è ancora 2.1.2), ma
> ora si presenta da subito... Non ho molti prodotti (essenzialmente utilizzo
> PloneExFile, attachmentfield 1.3.13, filesystemstorage 2.5.4, ploneglossary
> 1.3, fckeditor e portaltaxonomy 0.4). Per quanto riguarda il suggerimento
> di Yuri: mi sembra che l'unico prodotto con sottodirectory di nome plone
> sia Kupu... Grazie


Innanzitutto ti sconsiglio un utilizzo diretto di un plone migrato
automaticamente.
Fai pure la migrazione, ma poi sposta in contenuti su di un plone nuovo, con i
prodotti appena installati.

Fabrizio


--
Fabrizio Reale                               [hidden email]
Redomino S.r.l.                 Largo Valgioie 14 - 10146 Torino - Italy
Tel: +39 011 7499875 - Fax: +39 011 3716911     http://www.redomino.com/

_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

RE: AttributeError: @@plone

Zanotti Michele
>
> Innanzitutto ti sconsiglio un utilizzo diretto di un plone migrato
> automaticamente.
> Fai pure la migrazione, ma poi sposta in contenuti su di un
> plone nuovo, con i
> prodotti appena installati.
>
> Fabrizio

Scusami, intendi un Plonesite nuovo creato all'interno della stessa
istanza di Zope nella quale ho eseguito l'upgrade (e quindi lo stesso
data.fs) facendo un copia/incolla delle folder dei contenuti, oppure
proprio un export del mio plonesite e poi un import dello zexp su una
nuova istanza di Zope con un "nuovo" data.fs?
Ti ringrazio molto per la pazienza!
Michele


_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html
Reply | Threaded
Open this post in threaded view
|

Re: AttributeError: @@plone

Fabrizio Reale
Alle lunedì 4 giugno 2007, Zanotti Michele ha scritto:

> > Innanzitutto ti sconsiglio un utilizzo diretto di un plone migrato
> > automaticamente.
> > Fai pure la migrazione, ma poi sposta in contenuti su di un
> > plone nuovo, con i
> > prodotti appena installati.
> >
> > Fabrizio
>
> Scusami, intendi un Plonesite nuovo creato all'interno della stessa
> istanza di Zope nella quale ho eseguito l'upgrade (e quindi lo stesso
> data.fs) facendo un copia/incolla delle folder dei contenuti, oppure
> proprio un export del mio plonesite e poi un import dello zexp su una
> nuova istanza di Zope con un "nuovo" data.fs?
E sufficiente che sia un altro Plone all'interno dello stesso Zope (perciò
stesso Data.fs).
Ti consiglio questo perchè i contenuti di Plone sono abbastanza facili da
migrare, mentre la struttura (se mi permetti il termine) è un po' più
delicata :)

Saluti,
Fabry


--
Fabrizio Reale                               [hidden email]
Redomino S.r.l.                 Largo Valgioie 14 - 10146 Torino - Italy
Tel: +39 011 7499875 - Fax: +39 011 3716911     http://www.redomino.com/


_______________________________________________
Plone-IT mailing list
[hidden email]
http://lists.plone.org/mailman/listinfo/plone-it
http://www.nabble.com/Plone---Italy-f21728.html