A potential bug fix for timezones

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

A potential bug fix for timezones

James Purser-2
Hi all,

I'm just starting to get into plone (putting together a site for a
client) and I came across a problem with displaying of times. All times
seemed to be US/Eastern.

After further investigation it was discovered that because the Unix
Timezone files refer to both US Eastern Time and Australian Eastern Time
as EST, DateTime was pulling the US time.

The workaround can be found here:

https://bugs.launchpad.net/zope2/+bug/142148
--
James Purser
http://k-sit.com
0406 576 553


_______________________________________________
OzZope mailing list
[hidden email]
http://lists.ozzope.org/cgi-bin/mailman/listinfo/ozzope

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: A potential bug fix for timezones

Andrew Milton
+-------[ James Purser ]----------------------
| Hi all,
|
| I'm just starting to get into plone (putting together a site for a
| client) and I came across a problem with displaying of times. All times
| seemed to be US/Eastern.
|
| After further investigation it was discovered that because the Unix
| Timezone files refer to both US Eastern Time and Australian Eastern Time
| as EST, DateTime was pulling the US time.

Zope DateTime is wrong, and has been wrong for 10 years, and noone can
fix it.

| The workaround can be found here:
|
| https://bugs.launchpad.net/zope2/+bug/142148

Here's an easier way;

http://gabbpuy.blogspot.com/2006/04/australian-eastern-timezones-in-zope.html


--
Andrew Milton
[hidden email]
_______________________________________________
OzZope mailing list
[hidden email]
http://lists.ozzope.org/cgi-bin/mailman/listinfo/ozzope